T91-2020 BIOVIA Desktop Connector: Desktop Client fails if the Desktop Connector Service in the application server is incorrectly configured in the DesktopConnectorService/Api/web.config file
BIOVIA Desktop Connector 2020
Program
BIOVIA Desktop Connector 2020
Operating System
Background
Recently two instances of misconfiguration of the DesktopConnectorService/Api/web.config file were found, causing browsers not being able to connect to the service. The following error message was shown in the browser console.
DesktopConnector ERROR: CONNECT > Error: Invalid start response: ''. Stopping the connection.
In both instances, the failure was caused by the DesktopConnectorService being improperly configured to use an SQL Server database which is not supported.
This error does not occur if DesktopConnectorService is configured to use an Oracle database. Using a database should however normally be avoided unless required for load balancing purposes.
Example 1: DesktopConnectorService inherited database settings from Notebook
DesktopConnectorService was installed into the Notebook web site. Notebook used an SQL Server database and the Notebook database configuration parameters were specified in the RIA/web.config file.
The DATABASETYPE and DATABASESERVERNAME settings were not overridden in the DesktopConnectorService configuration (see Workaround below); causing DesktopConnectorService to inherit the database configuration from Notebook.
This situation can arise when upgrading from a version lower than 2018. In this situation, the DesktopConnectorService/Api/web.config file lacks the required keys within <appSettings> tag.
Example 2: DesktopConnectorService was explicitly configured to use an SQL Server database
On another instance, the web.config file had the keys but the key values were populated with database details, explicitly specifying an SQL Server. For example:
<appSettings>
<add key="DATABASESERVERNAME" value="2019SDB\SQLS2016"/>
<add key="DATABASETYPE" value="SQLSERVER"/>
...
</appSettings>
Workaround
Edit the DesktopConnectorService/Api/web.config file and make sure the required keys are there with the correct key values as shown below.
<appSettings>
<add key="DATABASETYPE" value="" />
<add key="DATABASESERVERNAME" value=""/>
...
</appSettings>
Save the file to resolve this issue.
BIOVIA Support
If you have any questions, please contact BIOVIA Support.