T60-2022 Notification regarding BIOVIA Foundation Hub 2022 SP1 Installation or Upgrade
BIOVIA Foundation Hub 2022 SP1 or higher
Program
BIOVIA Foundation Hub 2022 SP1 or higher.
Operating System
All supported operating systems
Description
This Technical Note is to inform you that a BIOVIA Foundation Hub installation or upgrade to 2022 SP1 or later will fail if the ‘compatible’ parameter in the Oracle database is set to 12.1 or lower.
Resolution
You can check the compatible setting by logging in as a DBA and issuing the following SQL:
SELECT name, value FROM v$parameter WHERE name = 'compatible';
Here is a sample result:
NAME VALUE
---------- ---------
Compatible 12.1.0.2.0
If the compatible parameter is set to 12.1 or lower, the upgrade to or installation of Foundation Hub 2022 SP1 will fail with the error:
ORA-00972: identifier is too long.
The error in the hub log appears similar to the following:
. . .
Caused By: Error executing SQL ALTER TABLE aud_sam_sample_plan_sample ADD CONSTRAINT aud_sam_sample_plan_sampl_rev_fk FOREIGN KEY (rev) REFERENCES cor_audit_revision (id): ORA-00972: identifier is too long
. . . .
The compatible parameter must be set to at least 12.2.0 before upgrading to BIOVIA Foundation Hub 2022 SP1.
The error is due to an Oracle limitation only, when trying to create an object that contains more than 30 characters. It is not a limitation or defect in BIOVIA Foundation Hub.
If you need to change this compatible setting, refer to Oracle’s documentation and back up the Oracle database prior to changing this. More information about this setting can be found in the articles below.
My Oracle Support:
How To Change The COMPATIBLE Parameter And What Is The Significance? (Doc ID 733987.1)
Here is some additional documentation regarding the ORA-00972 error:
How to contact BIOVIA Support
If you have any questions, please contact BIOVIA Support.