May 18 2021

T51-2021 BIOVIA Notebook 2021 SP1 integration with Foundation Hub 2020 SP1 or higher

BIOVIA Notebook

Program

BIOVIA Notebook 2021 SP1

Operating System

Microsoft Windows Server (64 bit), 2016 and 2019

Background

Hub Configuration

There is an attribute called notebookServer in the foundation.config.template file at C:\Program Files\BIOVIA\BIOVIA Notebook Software\NotebookLoginService\foundation.config.tempate.

If a foundation.config file is created using this template, the integration will fail due to this incorrect attribute as seen in the NotebookLoginService_xxxx.log file at C:\Program Files\BIOVIA\ BIOVIA Notebook Software\Log directory.

The error message is, for example:

yyyy/mm/dd hh:mm:ss.xxx ID:9 INFO No valid FoundationConfig section found in foundation.config file: Unrecognized attribute 'notebookServer'. Note that attribute names are case-sensitive. (C:\Program Files\BIOVIA\BIOVIA Notebook Software\NotebookLoginService\foundation.config line xx)

Create Task Plan

Creating a new Task Plan using the “Create” button in a Task Plan section will fail due to an error in the URL configured for this button.

Workaround

Hub Configuration

Change the attribute name “notebookServer” to “notebookHost” in the foundation.config file, save and restart the IIS.

Create Task Plan

This workaround is only for a new installation of Notebook 2021 SP1 and it is not required if the Notebook is upgraded to 2021 SP1

Connect to notebook database as eln user and correct the url for the Open Task Plan button.

Execute the following SQL statement:

UPDATE INTEGRATIONSECTIONURL SET URL = '${notebookrooturl}/api/v1/sections/${sectionId}/runset' WHERE URLID = (SELECT URLID FROM INTEGRATIONSECTIONBUTTONS WHERE INTEGRATIONSECTIONID = 299 AND BUTTONNAME = 'Create')

BIOVIA Support

If you have any questions, please contact BIOVIA Support.