T104-2021 BIOVIA Pipeline Pilot: AppCatalog indexing can cause Tomcat instability
BIOVA Pipeline Pilot
Program
Pipeline Pilot 2021
Operating System
All supported operating systems
Background
In some cases, the App Catalog protocol indexing that supports Protocol Search options can run into memory problems while indexing protocols within the Protocol Database. When this happens, it can cause the Tomcat server to become unresponsive. If this occurs, various application errors can result including failures to launch scheduled tasks, reporting chart failures, and application failures. If Foundation Hub is used as the authentication method, all logins to the server will begin to fail with various "proxy_http" errors reported in the Pipeline Pilot system logs.
If this occurs, the options are to either disable Protocol Database indexing or increase the Tomcat allocated memory.
The indexing can be disabled in the Admin Portal/Setup/Catalog Settings/ page by unchecking all seven days within the "Schedule Catalog Sync" section. You can confirm the task is disabled in the Admin Portal/Status/Scheduled Tasks page where package:scitegic_appcatalog_XXXXX will show a "Cron" schedule showing something like "0 0 1 ? * * 2000" where the date specification is in the past and so will not execute. Note that doing so will effectively turn off the protocol search feature.
Alternatively, you can try updating -Xms (min HeapSize) and -Xmx (max HeapSize) from the defaults of 128m/768m to 512m/1024m from Admin portal/Maintenance/Manage Server. Then restart Tomcat. You can verify the settings in the javaserver_tomcat_shared_catalina.log in lines similar to this:
2021-03-18 13:47:36,811 [org.apache.catalina.startup.VersionLoggerListener log ] INFO - Command line argument: -Xms512m 2021-03-18T13:47:36.811406200-07:00[America/Los_Angeles]
2021-03-18 13:47:36,811 [org.apache.catalina.startup.VersionLoggerListener log ] INFO - Command line argument: -Xmx1024m 2021-03-18T13:47:36.811406200-07:00[America/Los_Angeles]
Solution
This issue has been logged as defect PPC-10000. A fix is being considered for a future release of Pipeline Pilot.
How to contact BIOVIA Support
If you have any questions, please contact BIOVIA Support.