Oct 26 2018

T43-2016: Update regarding Vault Service Account for BIOVIA Workbook 2017

Workbook

With the release of Workbook 2017, Vocabularies were moved from Vault to Foundation Hub upon bootstrapping Vault with Foundation Hub. If you have created a custom Message Handler that retrieves Vocabularies in a Form (say), or a Review activity, then, Vault will need to authenticate its internal user account in Foundation Hub (namely, the "Vault Service Account") with Pipeline Pilot. In order to enable this authentication, please implement the steps that are listed in the Resolution in this Technical Note.
 
Operating System
All Operating Systems Supported with BIOVIA Workbook 2017
Resolution:
Note: In a load balanced environment, the following steps must be performed on each Vault server machine.
 
1. Login to the Vault server machine as a user with Administrator privileges.
 
2. In the Services panel on the Vault server machine, stop the Vault services and IIS as follows.

  • Vault Hub Synchronization Service
  • Vault Client Service
  • Vault Workflow Service
  • Vault Message Processing Service
  • Vault Tomcat Server
  • World Wide Web Publishing Service

 
3. In the folder, “<DRIVE>:\Program Files (x86)\BIOVIA\Vault\WebService\”, open the file, “web.config”, and note the following two sections. You may copy the following two sections from this file, and paste them into the file that is listed in Step 4 below.
 
<section name="authentication" type="Accelrys.AEP.Authentication.Configuration, Accelrys.AEP.Authentication, Version=6.9.0.0, Culture=neutral, PublicKeyToken=fb4b5791c48b7e8a" />
 
 
<authentication defaultAuthenticationProviderForSigning="AEP">
<uri>https://MyPipelinePilotServer.dsone.com:9943</uri>
<cache-time>00:05</cache-time>
</authentication>
 
4. In the folder, “<DRIVE>:\Program Files (x86)\BIOVIA\Vault\PrivateWebService\”, make a copy of the file, “web.config”. Open the original file for editing in Notepad. Add the two sections that are noted below.
 
(a) Add the following line in the “configSections” element. You may copy the information that you had collected in Step 3 above.
 
<section name="authentication" type="Accelrys.AEP.Authentication.Configuration, Accelrys.AEP.Authentication, Version=6.9.0.0, Culture=neutral, PublicKeyToken=fb4b5791c48b7e8a" />
 
(b) Add the following section as a sibling to the “configSections” element. You may copy the information that you had collected in Step 3 above.
 
<authentication defaultAuthenticationProviderForSigning="AEP">
<uri>Your Pipeline Pilot Server Name.domain.com:Port Number</uri>
<cache-time>00:05</cache-time>
</authentication>
 
Example:
<authentication defaultAuthenticationProviderForSigning="AEP">
<uri>MyPipelinePilotServer.dsone.com:9943</uri>
<cache-time>00:05</cache-time>
</authentication>
 
(c) Save and close the file.
 
5. In the Services panel on the Vault server machine, start IIS, and then, start the Vault Services as follows.

  • World Wide Web Publishing Service
  • Vault Tomcat Server
  • Vault Message Processing Service
  • Vault Workflow Service
  • Vault Client Service
  • Vault Hub Synchronization Service

 
6. Confirm that the web pages for Vault and RAS can be launched successfully. These web pages are typically accessed via the Start > BIOVIA menu (on Windows 2008 R2 SP1 Server) or via Apps > BIOVIA (on Windows 2012 Server).
 
7. Confirm that the login to Workbook Client is successful.
 
8. Confirm that any customizations, which you have created to retrieve Vocabularies via Form Views or a Review activity, are working correctly, and there are no authentication errors.
 
Defect # NBK-26350

How to contact BIOVIA Support
If you have any questions, please contact BIOVIA Support.
Error Mesage:
In the following error message, “svc_l1IghbWuPA-AkOHqMPDW-a”, refers to the Vault Service Account (a Vault user account in Foundation Hub). This error message is typically listed in the file, “VaultDebug.log”, in the folder, “VaultLogs”, on the Vault server machine.

 

Symyx.Framework.Vault.Faults.SymyxFault [(null)] - An exception occurred: Get Failed.

BIOVIA.Foundation.Exceptions.AuthenticationException: Could not log svc_l1IghbWuPA-AkOHqMPDW-a in to localhost using credentials provided. Reason: 'Unexpected' Message: 'Unable to connect to the remote server'