T07-2017 Apache May Fail to Restart after Upgrade to Pipeline Pilot 2017 R2
Pipeline Pilot Server
Rarely, after upgrading to Pipeline Pilot 2017 R2, the Apache Server will fail to start. You will see error messages like the one listed when trying to start Apache. The error is caused by one or more Apache configuration files not being updated during the upgrade and those configuration files contain directives that are no longer supported in Apache 2.4.
Resolution:
The Apache server for Pipeline Pilot 2017 R2 has been upgraded to version 2.4. This version of Apache no longer supports “Order”, “Allow”, or “Deny” directives and these directives were used by older versions of Pipeline Pilot in some Apache configuration files. If you encounter the error message, you must replace “Order”, “Allow”, or “Deny” directives with 'Required" directives.
Looking at Pipeline Pilot 2017 R2’s httpd-seqanal.conf file, that file replaces the “Order” and “Allow” directives with a “Require” directive as described in the error message. Copied below are examples of httpd-seqanal.conf from Pipeline Pilot 2016 and 2017 R2 to show how the directives must be edited.
NOTE: Other Apache configuration files may be reported in the error message and these files must also be edited to remove the retired Apache directives. Contact BIOVIA Customer Support for more information if needed.
httpd-seqanal.conf from 2016
# THIS FILE IS AUTOMATICALLY GENERATED. PLEASE BACKUP ANY CUSTOMIZATIONS
# AS THE FILE WILL BE OVEWRITTEN WHEN JAVASERVER PACKAGE IS REINSTALLED
Alias /seqanalperlbin/ "C:/Program Files/BIOVIA/PPS2016/apps/scitegic/seqanal/lang/perl/web/"
<Directory "C:/Program Files/BIOVIA/PPS2016/apps/scitegic/seqanal/lang/perl/web">
Options +ExecCGI -Indexes -IncludesNoExec
AllowOverride None
Order allow,deny
Allow from all
AddHandler perl-script pl
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
</Directory>
httpd-seqanal.conf from 2017 R2
# THIS FILE IS AUTOMATICALLY GENERATED. PLEASE BACKUP ANY CUSTOMIZATIONS
# AS THE FILE WILL BE OVEWRITTEN WHEN JAVASERVER PACKAGE IS REINSTALLED
Alias /seqanalperlbin/ "C:/Program Files/BIOVIA/PPS2017R2/apps/scitegic/seqanal/lang/perl/web/"
<Directory "C:/Program Files/BIOVIA/PPS2017R2/apps/scitegic/seqanal/lang/perl/web">
Options +ExecCGI -Indexes -IncludesNoExec
AllowOverride None
Require all granted
AddHandler perl-script pl
#PerlResponseHandler ModPerl::Registry
#PerlOptions +ParseHeaders
</Directory>
Error Mesage:
AH00526: Syntax error on line 9 of C:/Program Files/Accelrys/PPS/web/conf/httpd-seqanal.conf:
Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration
Checking files in web/conf...
ERROR: web/conf/httpd-seqanal.conf contains one or more Apache 'Order', 'Allow', or 'Deny' directives that must be replaced with Apache 2.4 'Require' directives. See https://httpd.apache.org/docs/2.4/upgrading.html for details.
****Errors shown above must be corrected prior to starting the Pipeline Pilot server****”