T05-2017: CISPro 2017 R2 Print Client license key is invalid
CISPro Cloud
The 2017 R2 Print Client requires a license key to be validated with the CISPro server. However, on attempting to "Load Key File" with the key.txt file downloaded from the server (with the Print Client installer) an error is thrown.
Resolution:
This issue has been logged as a defect (issue number CIS-64296) and will be addressed in BIOVIA CISPro and CISPro Cloud 2017 R2 SP1 HF1
Meanwhile this issue can be worked-around by editing the key.txt file downloaded with the Print Client. The key.txt can be edited in any text editor (e.g. Notepad). The server name within key.txt needs to be changed to reflect the actual CISPro server name, i.e. replace "chemsenbttemp" with "nbtlive.chemswlive.com" for Cloud customers.
For example:
{"BaseUrl":"https://chemsenbttemp/nbtwebapp/Services/NbtPublic.svc","SooperSecretKey":"...
Should be edited to:
{"BaseUrl":"https://nbtlive.chemswlive.com/nbtwebapp/Services/NbtPublic.svc","SooperSecretKey":"...
Error Mesage:
There was no endpoint listening at https://chemsenbttemp/nbtwebapp/Services/NbtPublic.svc/ValidateKey that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.