Important Critical Hotfix (February 2017)

It has come to the attention of the DraftSight team that, due to an expired certificate, Windows* 32 & 64-bit versions of DraftSight released from 2012 to 2017 will not launch and/or will stop running as of March 1, 2017. However, we are making available a critical hotfix to resolve this issue before that date. 

To avoid usage interruption, please make sure to immediately download and install this critical hotfix, which can be found on the main product download page

The affected releases are as follows: 

We apologize for any inconvenience and continue to be fully committed to providing the highest quality of software solutions for our growing community of DraftSight users. 

*Note: Mac and Linux versions of DraftSight (Free and Beta only) do not require this hotfix as they are not affected by the expired certificate.